const regex = new RegExp('^\\s*(Leader|Head\\\\Organiser|Head|Head\\\\Secretary|Captain|Vice Captain)[ \\t:-]+(.*?)[ \\t]*[;#]+', 'gm')
const str = `Leader : Tim Lee ; 34567
Head\\Organiser: Sam Mathews; 11:53 am
Head: Alica Mills; 45612
Head\\Secretary: Maya Hill; #53190
Captain- Jocey David # 45123
Vice Captain:- Jacob Green; -65432
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}