// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(Leader|Head\\Organiser|Head|Head\\Secretary|Captain|Vice Captain)[ \t:-]+(.*?)[ \t]*[;#]+").unwrap();
let string = "Leader : Tim Lee ; 34567
Head\\Organiser: Sam Mathews; 11:53 am
Head: Alica Mills; 45612
Head\\Secretary: Maya Hill; #53190
Captain- Jocey David # 45123
Vice Captain:- Jacob Green; -65432
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}