#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*xyz).*abc.*"
Local $sString = "kadjs ölkajsd öl öjasd abc ladkjskjasd" & @CRLF & _
"kjasd kljasdhjabc djslkasd xyz asdkljaölsdkjds" & @CRLF & _
"ladhlakjsdh d lahsdkljhads kja d" & @CRLF & _
"hjqwge kuadsl hlasd abc adjöladjs öajds" & @CRLF & _
"xyz adökljadsö aösdj ö abc adskj aäölds" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")