import Foundation
let pattern = #"^(?!.*xyz).*abc.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kadjs ölkajsd öl öjasd abc ladkjskjasd
kjasd kljasdhjabc djslkasd xyz asdkljaölsdkjds
ladhlakjsdh d lahsdkljhads kja d
hjqwge kuadsl hlasd abc adjöladjs öajds
xyz adökljadsö aösdj ö abc adskj aäölds
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)