using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*xyz).*abc.*";
string input = @"kadjs ölkajsd öl öjasd abc ladkjskjasd
kjasd kljasdhjabc djslkasd xyz asdkljaölsdkjds
ladhlakjsdh d lahsdkljhads kja d
hjqwge kuadsl hlasd abc adjöladjs öajds
xyz adökljadsö aösdj ö abc adskj aäölds
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}