$re = '/^(?!.*xyz).*abc.*/m';
$str = 'kadjs ölkajsd öl öjasd abc ladkjskjasd
kjasd kljasdhjabc djslkasd xyz asdkljaölsdkjds
ladhlakjsdh d lahsdkljhads kja d
hjqwge kuadsl hlasd abc adjöladjs öajds
xyz adökljadsö aösdj ö abc adskj aäölds
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);