use strict;
my $str = 'kadjs ölkajsd öl öjasd abc ladkjskjasd
kjasd kljasdhjabc djslkasd xyz asdkljaölsdkjds
ladhlakjsdh d lahsdkljhads kja d
hjqwge kuadsl hlasd abc adjöladjs öajds
xyz adökljadsö aösdj ö abc adskj aäölds
';
my $regex = qr/^(?!.*xyz).*abc.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}