import re
regex = re.compile(r"(?<id>\/f\/\d+\/\d+x\d+\/\w+\/[^\/]+)\/?(?<modifiers>m\/?(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<width>\-?\d+)x(?<height>\-?\d+))?\/?(?<filters>filters\:[^\/]+)?)?$", flags=re.MULTILINE)
test_str = ("/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()\n"
"/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130\n"
"/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)\n"
"/f/39898/1000x600/d962430746/demo-image-human.jpeg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")