// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<id>\/f\/\d+\/\d+x\d+\/\w+\/[^\/]+)\/?(?<modifiers>m\/?(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<width>\-?\d+)x(?<height>\-?\d+))?\/?(?<filters>filters\:[^\/]+)?)?$").unwrap();
let string = "/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()
/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130
/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)
/f/39898/1000x600/d962430746/demo-image-human.jpeg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}