using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)<div(?=(?:[^>""']|""[^""]*""|'[^']*')*?\sid\s*=\s*(?:(['""])\s*(post-\d+).*?\1))\s+(?:"".*?""|'.*?'|[^>]*?)+>";
string input = @"<div class=""main>
<div id=""post-1111:"">
<div class=junk id=""post-1112:"">
<div id=""post-1113:"" class=junk >
<div class=junk id=""data-1122:"" id=""post-1114:"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}