import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)<div(?=(?:[^>\"']|\"[^\"]*\"|'[^']*')*?\\sid\\s*=\\s*(?:(['\"])\\s*(post-\\d+).*?\\1))\\s+(?:\".*?\"|'.*?'|[^>]*?)+>";
final String string = "<div class=\"main>\n"
+ "<div id=\"post-1111:\">\n"
+ "<div class=junk id=\"post-1112:\">\n"
+ "<div id=\"post-1113:\" class=junk >\n"
+ "<div class=junk id=\"data-1122:\" id=\"post-1114:\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}