re = /(?si)<div(?=(?:[^>"']|"[^"]*"|'[^']*')*?\sid\s*=\s*(?:(['"])\s*(post-\d+).*?\1))\s+(?:".*?"|'.*?'|[^>]*?)+>/m
str = '<div class="main>
<div id="post-1111:">
<div class=junk id="post-1112:">
<div id="post-1113:" class=junk >
<div class=junk id="data-1122:" id="post-1114:">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end