$re = '/(?si)<div(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\sid\s*=\s*(?:([\'"])\s*(post-\d+).*?\1))\s+(?:".*?"|\'.*?\'|[^>]*?)+>/m';
$str = '<div class="main>
<div id="post-1111:">
<div class=junk id="post-1112:">
<div id="post-1113:" class=junk >
<div class=junk id="data-1122:" id="post-1114:">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);