const regex = /(?si)<div(?=(?:[^>"']|"[^"]*"|'[^']*')*?\sid\s*=\s*(?:(['"])\s*(post-\d+).*?\1))\s+(?:".*?"|'.*?'|[^>]*?)+>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)<div(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\\sid\\s*=\\s*(?:([\'"])\\s*(post-\\d+).*?\\1))\\s+(?:".*?"|\'.*?\'|[^>]*?)+>', 'gm')
const str = `<div class="main>
<div id="post-1111:">
<div class=junk id="post-1112:">
<div id="post-1113:" class=junk >
<div class=junk id="data-1122:" id="post-1114:">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}