package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<startwort>AB[\w\d]+)\s+(?<startplus>(AB[\w\d]+\s+)+)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>\w+)\s+(?<betrag>[\d.,]+)\s*$`)
var str = `AB0007711 CD0TZUUZ AB899979 At vero eos et 10 100 XYZ 1.223,50`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}