const regex = /^(?<startwort>AB[\w\d]+)\s+(?<startplus>(AB[\w\d]+\s+)+)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>\w+)\s+(?<betrag>[\d.,]+)\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<startwort>AB[\\w\\d]+)\\s+(?<startplus>(AB[\\w\\d]+\\s+)+)(?<vorwort>.*)\\s+(?<zahl>\\d+)\\s+(?<wort>\\w+)\\s+(?<betrag>[\\d.,]+)\\s*$', '')
const str = `AB0007711 CD0TZUUZ AB899979 At vero eos et 10 100 XYZ 1.223,50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}