re = /^(?<startwort>AB[\w\d]+)\s+(?<startplus>(AB[\w\d]+\s+)+)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>\w+)\s+(?<betrag>[\d.,]+)\s*$/
str = 'AB0007711 CD0TZUUZ AB899979 At vero eos et 10 100 XYZ 1.223,50'
# Print the match result
str.match(re) do |match|
puts match.to_s
end