import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<startwort>AB[\\w\\d]+)\\s+(?<startplus>(AB[\\w\\d]+\\s+)+)(?<vorwort>.*)\\s+(?<zahl>\\d+)\\s+(?<wort>\\w+)\\s+(?<betrag>[\\d.,]+)\\s*$";
final String string = "AB0007711 CD0TZUUZ AB899979 At vero eos et 10 100 XYZ 1.223,50";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}