import Foundation
let pattern = #"^(?<startwort>AB[\w\d]+)\s+(?<startplus>(AB[\w\d]+\s+)+)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>\w+)\s+(?<betrag>[\d.,]+)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"AB0007711 CD0TZUUZ AB899979 At vero eos et 10 100 XYZ 1.223,50"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}