# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/Paragraph>.*\s*)(<Hyperlink.*)/$1<Paragraph>$2<\/Paragraph>/g;t' <<< "</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri=\"https://somelink.com\">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri=\"https://somelink.com\">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri=\"https://somelink.com\">July 14, 2017</Hyperlink>"