import Foundation
let pattern = #"(<\/Paragraph>.*\s*)(<Hyperlink.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<Paragraph>$2</Paragraph>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)