$re = '/(<\/Paragraph>.*\s*)(<Hyperlink.*)/';
$str = '</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>';
$subst = "$1<Paragraph>$2</Paragraph>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;