use strict;
my $str = '</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>';
my $regex = qr/(<\/Paragraph>.*\s*)(<Hyperlink.*)/p;
my $subst = '$1<Paragraph>$2</Paragraph>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";