const regex = /(<\/Paragraph>.*\s*)(<Hyperlink.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/Paragraph>.*\\s*)(<Hyperlink.*)', 'g')
const str = `</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>
</Paragraph> some words here (@somevaluehere1)
<Hyperlink NavigateUri="https://somelink.com">July 14, 2017</Hyperlink>`;
const subst = `$1<Paragraph>$2</Paragraph>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);