using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"WS\s+(.+)\s+(.+)\s+(\d{4}-\d{2})\s+(.+)";
string input = @"WS Bond State Market 2019-03 Active";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}