package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)WS\s+(.+)\s+(.+)\s+(\d{4}-\d{2})\s+(.+)`)
var str = `WS Bond State Market 2019-03 Active`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}