// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)WS\s+(.+)\s+(.+)\s+(\d{4}-\d{2})\s+(.+)").unwrap();
let string = "WS Bond State Market 2019-03 Active";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}