$re = '/WS\s+(.+)\s+(.+)\s+(\d{4}-\d{2})\s+(.+)/m';
$str = 'WS Bond State Market 2019-03 Active';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);