re = /WS\s+(.+)\s+(.+)\s+(\d{4}-\d{2})\s+(.+)/m
str = 'WS Bond State Market 2019-03 Active'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end