using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9](?:\.[a-zA-Z]{2,})+$";
string input = @"example.com
sub.eample.com
sub-dash.example.com
sub.sub2-dash.example.com
sub.example-dash.com
sub123.example.com
sub.sub123.example.com
www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}