$re = '/^[a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9](?:\.[a-zA-Z]{2,})+$/m';
$str = 'example.com
sub.eample.com
sub-dash.example.com
sub.sub2-dash.example.com
sub.example-dash.com
sub123.example.com
sub.sub123.example.com
www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);