// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9](?:\.[a-zA-Z]{2,})+$").unwrap();
let string = "example.com
sub.eample.com
sub-dash.example.com
sub.sub2-dash.example.com
sub.example-dash.com
sub123.example.com
sub.sub123.example.com
www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}