package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9](?:\.[a-zA-Z]{2,})+$`)
var str = `example.com
sub.eample.com
sub-dash.example.com
sub.sub2-dash.example.com
sub.example-dash.com
sub123.example.com
sub.sub123.example.com
www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}