import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9](?:\\.[a-zA-Z]{2,})+$";
final String string = "example.com\n"
+ "sub.eample.com\n"
+ "sub-dash.example.com\n"
+ "sub.sub2-dash.example.com\n"
+ "sub.example-dash.com\n"
+ "sub123.example.com\n"
+ "sub.sub123.example.com\n"
+ "www.thisislongerthansixtyonecharacterswhichisnotallowedbythestandards.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}