using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ул(ица|\.)? +гранатная *(,|\.|\r|\n|$)|ул(ица|\.)? +гранатная +(7а( +(к3))?) *(,|\.|\r|\n|$)";
string input = @"улица Гранатная 1, ул Гранатная, улица Гранатная 2, ул Гранатная 7а, улица Гранатная 7, ул. Гранатная 7а к3";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}