$re = '`ул(ица|\.)? +гранатная *(,|\.|\r|\n|$)|ул(ица|\.)? +гранатная +(7а( +(к3))?) *(,|\.|\r|\n|$)`im';
$str = 'улица Гранатная 1, ул Гранатная, улица Гранатная 2, ул Гранатная 7а, улица Гранатная 7, ул. Гранатная 7а к3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);