import re
regex = re.compile(r"ул(ица|\.)? +гранатная *(,|\.|\r|\n|$)|ул(ица|\.)? +гранатная +(7а( +(к3))?) *(,|\.|\r|\n|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "улица Гранатная 1, ул Гранатная, улица Гранатная 2, ул Гранатная 7а, улица Гранатная 7, ул. Гранатная 7а к3"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")