// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)ул(ица|\.)? +гранатная *(,|\.|\r|\n|$)|ул(ица|\.)? +гранатная +(7а( +(к3))?) *(,|\.|\r|\n|$)").unwrap();
let string = "улица Гранатная 1, ул Гранатная, улица Гранатная 2, ул Гранатная 7а, улица Гранатная 7, ул. Гранатная 7а к3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}