re = /ул(ица|\.)? +гранатная *(,|\.|\r|\n|$)|ул(ица|\.)? +гранатная +(7а( +(к3))?) *(,|\.|\r|\n|$)/im
str = 'улица Гранатная 1, ул Гранатная, улица Гранатная 2, ул Гранатная 7а, улица Гранатная 7, ул. Гранатная 7а к3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end