package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
[[:blank:]\h]{0,2}
(?<!\\)
(?<line_all>
[[:blank:]\h]?
(?<line_type>\*|\-|\_)
[[:blank:]\h]?
){3,}
[ \t]*
$`)
var str = `* * *
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}