re = /^
[[:blank:]\h]{0,2}
(?<!\\)
(?<line_all>
[[:blank:]\h]?
(?<line_type>\*|\-|\_)
[[:blank:]\h]?
){3,}
[ \t]*
$/mx
str = '* * *
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end