$re = '/^
[[:blank:]\h]{0,2}
(?<!\\\\)
(?<line_all>
[[:blank:]\h]?
(?<line_type>\*|\-|\_)
[[:blank:]\h]?
){3,}
[ \t]*
$/mx';
$str = '* * *
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);