const regex = /^
[[:blank:]\h]{0,2}
(?<!\\)
(?<line_all>
[[:blank:]\h]?
(?<line_type>\*|\-|\_)
[[:blank:]\h]?
){3,}
[ \t]*
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
[[:blank:]\\h]{0,2}
(?<!\\\\)
(?<line_all>
[[:blank:]\\h]?
(?<line_type>\\*|\\-|\\_)
[[:blank:]\\h]?
){3,}
[ \\t]*
$', 'gm')
const str = `* * *
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}