#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\bINSERT INTO \w+\s.*?;\s*$"
Local $sString = "DROP TABLE IF EXISTS table1;" & @CRLF & _
"" & @CRLF & _
"ALTER TABLE table1 DROP PRIMARY KEY;" & @CRLF & _
"" & @CRLF & _
"INSERT INTO table1 (id, created, name, telefonnummer, erPatient_id) VALUES" & @CRLF & _
" (1, '2015-08-06 12;09:08', ' ', ' ', 16528)," & @CRLF & _
" (2, '2015-08-06 12:43:11', ' ', ' ', 16529)" & @CRLF & _
";" & @CRLF & _
"" & @CRLF & _
"INSERT INTO table2 (comment, id) VALUES" & @CRLF & _
"('hello this is a semicolon ;', 2);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")