import Foundation
let pattern = #"\bINSERT INTO \w+\s.*?;\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
DROP TABLE IF EXISTS table1;
ALTER TABLE table1 DROP PRIMARY KEY;
INSERT INTO table1 (id, created, name, telefonnummer, erPatient_id) VALUES
(1, '2015-08-06 12;09:08', ' ', ' ', 16528),
(2, '2015-08-06 12:43:11', ' ', ' ', 16529)
;
INSERT INTO table2 (comment, id) VALUES
('hello this is a semicolon ;', 2);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)