# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bINSERT INTO \w+\s.*?;\s*$"
test_str = ("DROP TABLE IF EXISTS table1;\n\n"
"ALTER TABLE table1 DROP PRIMARY KEY;\n\n"
"INSERT INTO table1 (id, created, name, telefonnummer, erPatient_id) VALUES\n"
" (1, '2015-08-06 12;09:08', ' ', ' ', 16528),\n"
" (2, '2015-08-06 12:43:11', ' ', ' ', 16529)\n"
";\n\n"
"INSERT INTO table2 (comment, id) VALUES\n"
"('hello this is a semicolon ;', 2);")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.