$re = '/\bINSERT INTO \w+\s.*?;\s*$/ms';
$str = 'DROP TABLE IF EXISTS table1;
ALTER TABLE table1 DROP PRIMARY KEY;
INSERT INTO table1 (id, created, name, telefonnummer, erPatient_id) VALUES
(1, \'2015-08-06 12;09:08\', \' \', \' \', 16528),
(2, \'2015-08-06 12:43:11\', \' \', \' \', 16529)
;
INSERT INTO table2 (comment, id) VALUES
(\'hello this is a semicolon ;\', 2);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);