use strict;
my $str = 'DROP TABLE IF EXISTS table1;
ALTER TABLE table1 DROP PRIMARY KEY;
INSERT INTO table1 (id, created, name, telefonnummer, erPatient_id) VALUES
(1, \'2015-08-06 12;09:08\', \' \', \' \', 16528),
(2, \'2015-08-06 12:43:11\', \' \', \' \', 16529)
;
INSERT INTO table2 (comment, id) VALUES
(\'hello this is a semicolon ;\', 2);';
my $regex = qr/\bINSERT INTO \w+\s.*?;\s*$/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}