#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:--[A-Z]{2}|[A-Z]{2}(?:--|[A-Z]{2}))\d{2}/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}\.png$"
Local $sString = "ABCD12/123e4567-e89b-12d3-a456-426614174000.png" & @CRLF & _
"--CD12/123e4567-e89b-12d3-a456-426614174000.png" & @CRLF & _
"AB--12/123e4567-e89b-12d3-a456-426614174000.png" & @CRLF & _
"" & @CRLF & _
"AB12--/123e4567-e89b-12d3-a456-426614174000.png" & @CRLF & _
"A-B-12/123e4567-e89b-12d3-a456-426614174000.png" & @CRLF & _
"A--D12/123e4567-e89b-12d3-a456-426614174000.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")