const regex = new RegExp('^(?:--[A-Z]{2}|[A-Z]{2}(?:--|[A-Z]{2}))\\d{2}/[0-9A-F]{8}(?:-[0-9A-F]{4}){3}-[0-9A-F]{12}\\.png$', 'gmi')
const str = `ABCD12/123e4567-e89b-12d3-a456-426614174000.png
--CD12/123e4567-e89b-12d3-a456-426614174000.png
AB--12/123e4567-e89b-12d3-a456-426614174000.png
AB12--/123e4567-e89b-12d3-a456-426614174000.png
A-B-12/123e4567-e89b-12d3-a456-426614174000.png
A--D12/123e4567-e89b-12d3-a456-426614174000.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}